thermoking tripac apu 2007

nismax

New Member
very complex problem that i am experiencing evaporator freezing and shuts off engine.
I have this problem for 2 weeks and cant figure it out.
pressures 110/30
clutch air gaps is in specs.
replaced hpco and lpco switches
removed evaporator cleaned inside and outside
replaced expansion valve and dryer

i do have power to fans and all is working fine for 3-5 mins then evaporator freezes for some reason my thermostat on evaporator is not disengaging clutch before it freezes and before engine shuts of i get clutch sliping like on/off for 10-15 times before engine is shut off with ACS code.

if you have any ideas what might be proble please let me know.

thanks
 

nismax

New Member
Issue I had with pictures and how I fixed it.

I think what my proble is, i have not fixed it yet but clutch coil wire is grounded deap down, visually cant see wire being damaged but its 100% grounded. i did test probe thing to find out if its grounded and probe light comes on. i jyst need to take coil off and see where its touching.
Thanks for replay
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Users who are viewing this thread

Top